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1. Goals

This tutorial is for students to learn and practice basic database operations with MS Access. Particularly,
after the tutorial, students will know the basics of:

How to define tables in MS Access;

e How to create forms for data browsing and data entry;
e How to customize a form for better user/data interaction;
e How to create SQL/queries for search and retrieval.

2. Data

In this tutorial, we will work on two tables, i.e., Department and Employee, as shown in Figure 1. There
is a one-to-many relationship between Department and Employee. That is, a department can have
multiple employees while each employee belongs to one department (through the foreign key DNO).

One possible database state for the COMPANY relational database schema.

EMPLOYEE
Fname Minit Lname Ssn Bdate Address Sex |Salary | Super_sen | Dno
._)ol_’\n B Smi!h 1 2ﬂ34_56789u 19§5-0_1 -09 '7"31 For\d(gn, Hoqs!qn, TX| M 30000 _33349555:_, 75
Franklin T Wong 338445555 | 1855-12-08 | 638 Voss, Houston, TX M |40000 |888665555 5
Alicia J Zelaya | 999887777 | 1968-01-19 | 8321 Castle, Spring, TX F 25000 |9876543821 4
Jennifer S Wallace | 987654321 | 1841-06-20 | 291 Berry, Bellaire, TX F 43000 (8886655565 4
Ramesh K Narayan | 666884444 | 1962-09-15 | 975 Fire Oak, Humble, TX | M | 38000 |333445555 5
Joyce A English | 453453453 | 1872-07-31 | 5631 Rice, Houston, TX F 25000 |338445555 5
Ahmad Vv Jabbar | 987087987 | 1969-03-29 | 980 Dallas, Houston, TX M |25000 |987654321 4
James E Borg 888665555 | 19837-11-10 | 450 Stone, Houston, TX M |85000 |NULL 1
DEPARTMENT
Dname Dnumber Mgr_ssn Mgr_start_date
Research 5 333445555 1988-05-22
Administration 4 987654321 1995-01-01
Headquarters 1 888665555 1981-06-19

Figure 1: Two Tables
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3. Database Creation

3.1. Start MS Access
To start Access, select START -> All Programs -> Microsoft Office -> Microsoft Office Access 2007.
3.2 New a Database

Now follow Figure 2 (a), (b), and (c) to create a new blank database. Please close the Tablel automatically
created (shown in Figure 2 (c)).

Blank Database

Mo i Create a Microsoft Office Access database that does
e not contain any existing data or objects.

File Name:
> | New (Ctri=N) = .
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C:\Users\weimao\Documents),
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(a) To new a database (b) Database name & path (c) Database created

Figure 2: New Database

4. Table Definition

Now follow Figure 3 (a), (b) to create and define a new table, e.g., the Department table. To define a
primary key, select the filed/attribute you want and click the Primary Key button, as shown in Figure 3 (b).

Database Tosts

A )iF company : Database ( .
Al Tabiss RIET — K
Homz Create Extemal Data Database Too Field Bawe Datailype Dimceintaag a
Daee Text departnent naac
i Table ¥ Dousber Sunber departnent naber (Ld)
] Funber departnent asnager SS§
[0=] Table Templates ~ | = Xsr_Start Date Date/Tiae departnent aanaser start date

Table
1ll] SharePoint Lists ~ |pesign

Tables Fragucty
b General Lopkupl
: All Tables New Object: Table el e Lo Inkeges
‘ Create a new blank table in Design e e o
view, You can add ficlds, set
indexing options, and perform
othsr advanced table design tasks. - hesiors
63 (Mo Dusticates)
Senews
Design mew P = Jutch panes. 11 = Help. Ea uiﬂ
(a) To design a table (b) Table Design View

Figure 3: Table Definition

To decide what data type you should use for each field, look at Table 1 for basic data types in MS Access
and Table 2 for various Number types in Appendix.



After you are done with the table design, click the Save button or simply press Ctrl + S to save the design.
Now you can click the Home tab and then the View button for browsing and/or entering data, as shown in
Figure 4.

5 Relationship and Constraint Definition

Select the Database Tools tab and then click on the Relationships button. When shown a popup window
with a list of tables, select each table at a time and click Add button to include both tables in the
relationships view, as shown in Figure 5. Close the popup window.

Now, to define a relationship between two tables, drag the related field from one table to the other.

For example, table Employee should have a foreign key referring to Department. Hence, we can drag the
field DNo of table Employee to the field DNumber of table Department. Now, the system will pop up an
Edit Relationships window, shown in Figure 6 (a), which allows you to select additional options,
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Figure 5: Add Tables to Relationships



e.g., for referential integrity (foreign key constraint) and cascading update/delete (triggers). Please check
the Enforce Referential Integrity option only and click the Create button. Figure 6 (b) shows a defined
relationship between Department and Employee. Click the Save button or press Ctrl + S to save. Close the
Relationships view.

6. Forms

Form is a useful tool for data browsing and manipulation. It provides various tools for the
design/customization of user-data interactions. Forms can run on Tables directly, or on Queries, which we
will discuss in Section 7.

6.1 Form Basics

The easiest way to create a form is to use the automatic form tools or wizards. As shown in Figure 7 (a),
select the table (or query) you want the form to be based on and click the Create -> Form button. Figure 7
(b) shows a form thus created based on the Department table. Click the Save button or press Ctrl + S to
save the design. Click the View button (to the very left) to browse existing data. Note that on the
Department form just created, related Employee records are also attached — the system knows the one-
to-many relationship we defined earlier. Once a form is opened, you can switch between three views by
using the View button, e.g., the Form view (which shows data and allows user interactions), the Design
view (which allows you to redesign the form), and the Layout view (which offers both interaction and
design functionality).
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Figure 6: Relationships of Tables

/6,, ) A B company : Database (Acc
|
/ Home Create External Data Database Tools Acrobat
= = =] Department
— Tl E = fi3 PivotChart E
: @ = L) = =] - ¥
S jBIank Form . Eevionriees
Table Table SharePoint Table Form | Split Multiple Form
Templates~ Lists~  Design Form ltems T2)More Forms ~ Design
Tables Forms
"l| All Tables Form
Department Create a form that lets you enter
. % information for one record ata
] Department : Table T
Employee
B Employee : Table ©) PressFLtor more help.
[hsea e e 0w

(a) Form wizards (b) Form created

Figure 7: Creating Forms



6.2 Form Customization
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Figure 8: Form Design View

Forms provide much richer tools for user-data interaction. For example, in the Employee table, we use
data type Yes/No for the Sex field. Technically, this is okay and saves data space. However, it is not
intuitive (and not making sense) to use Yes/No to represent Male/Female in the data view.

A better alternative to this is, without changing the data type, to show Male/Female to the user and to
allow the user to select Male or Female in data entry. Now let’s see how we can use Form to do this.

1. select the Employee table in the list of tables;

2. select the Create tab and then the Mulitple Items form button;
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Figure 9: Redesign the Sex Field with a Combo

3. now a form based the Employee table has been automatically created, shown in Figure;
4. click Home -> View -> Design View so that we can modify the form design;
5. Redesign the Sex field:
(a) remove the Sex field (check box) from the form;
(b) add a Combo Box (Form Control, from the red circled in Figure 8) in the form Detail area:
i. first, toggle select the Combo Box button;
ii. second, drag a (combo) box in the Detail area of the form;
(c) folow Figure 9 (a), (b), (c), and (d) to use a Combo Box for the Sex field;

Move the Sex field (Combo Box) to a proper position (Figure 10 (a)). Now, if you switch to the Form view,
the Sex field shows both the codes and labels (Male/Female) — still not what we expected (Figure 10 (b)).

Now, switch back to the Design view, select the Combo Box of the Sex field, click the Property Sheet
button (top right), and change the Format -> Column Widths option to 0”; 1” (set the width of column 1 to

0 to hide it), as shown in Figure 10 (c). In the final display (Figure 10 (d)), only sex labels (Male or Female)
are shown.

6.3 Easier Approach

There is an easier way to customize the Sex field with the table design view. First, open the design view
for table Employee and then select the Sex field. On the properties panel (bottom), select the Lookup tab
and enter the following property values:

e Row Source Type: Value List

e  Row Source: 0; Female; -1; Male



Address Sex Salary Super_SSN
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Figure 10: Combo Box: Final Adjustment

e Bound Column: 1
e Column Count: 2
e  Column Widths: 0”;1”

Now when you switch to the Datasheet View or create a new form based on the table, the system will
automatically use a Combo Box (with Male/Female labels) for the Sex field.

7.5QL Queries

Now let’s assume that we need to retrieve all employees (Names and SSNs) in the department named
Research, in the order of their last names.

To create a query, click Create -> Query Design. Add both Department and Employee tables to the

query design view. Because we’ve already defined the relationship between Department and Employee, a
JOIN statement is automatically generated (i.e., the two tables are connected, as shown in Figure 11 (a)).
Drag fields (to project Department.Dname, Employee.Fname, Employee.Lname, Employee.SSN) to the
grid area. Put “Research” in the criteria for the Dname field and set the Sort property of the Lname field
to “Ascending.” (see Figure 11 (a)) for detail.

After query definition, you can click the Save button or press Ctrl + S to save it. Now you can switch
between multiple views, as shown in Figure 11 (b). To see/edit the SQL script of the query, click SQL View

and the codes will be shown (Figure 11 (c)).

To run the query, click the Datasheet View shown in Figure 11 (b).




8. Documentation

To document all you have created, c

you can select tables, queries, forms,

lick Database Tools -> Database Documenter. As shown in Figure 12,
and relationships (under the Current Database tab) to generate a

report. When the report is shown, you can export it to various formats including RTF (as shown in Figure

13).

o
. A —' 33 Copy
View Paste
- = J Format F
Datasheet View [ ||
e L qryResearchEmployees
— SELECT Department Dname, Emploree. Fname, Emploryee.Minit.
j PivotTable View Emploree. Lname. Emploree. SSN
- FROM Department INKER JOIN Emplores

ON Department. Dnumber = Emplores. Dno
WHERE (((Department. Dname)="Research™))
OFDER EY Employee.lname:

Fiald: [rase

==

- - e 4 |SQL| sqL view \{
% Design View
(a) Query Design (b) Views (c) sQL View
Figure 11: Query Definition
@ - CE) . - ccgpany-[)ataoasc (Ac:essZOOﬂJMicroso&Acccss =B8] %
| Home Create External Data [ Database Tools | Acrobat @
= (%7 Preperty Sheet @ Database Documenter ‘ L&jl{ 5} Switchbaard Manager H?E@
il = .
i =3 7] Object Dep ies ‘ (5% Encrypt with Password
Relationships | SQL  Access Lmkzd Table . i ke
V| Message Bar @Analyze'l’able ‘ Server Database ‘ Manzger @ Add-ins ACCDE
‘ Show/Hide Analyze || MoveData | Database Tools
1%

i@ Security Warning Certain content in the database has been disabled ‘ Options.., | ‘

@ qryResearchEmployees
E frmDepartment
@ frmDepartment2

All Tables T =
epartment E | Modules Current Database @ All Object Types
Department : Table Tables Queries l 2 Forms I B8 Reports l 3 Maaos

v v E Department

¥ B S

Employee
= Employee : Table

@ qryResearchEmployees
@ frmEmployee
@ frmEmployee2

[=2] Print Table Definition

— Indude for Table

i
i

|| Permissions by User and Group

Include for Fields

(") Nothing

() Names, Data Types, and Sizes

(@) Names, Data Types, Sizes, and Properties

Incdude for Indexes

() Nothing

(7) Names and Fields

1@ Names, Fields, and Prope-ties

Documenter

==
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Appendix

Setting

Type of Data

Size

Text

(Default) Text or combinations of text and
numbers, as well as numbers that don’t require
calculations, such as phone numbers.

Up to 255 characters
or set by FieldSize,
whichever is less.

Memo

Lengthy text or combinations of text and numbers.

Up to 63,999 characters.

Number

Numeric data used in mathematical calculations.

1, 2,4, or 8 bytes

Date/Time

Date and time values for the years 100 through
9999.

8 bytes

Currency

Currency values and numeric data, accurate to 15
digits on the left side of the decimal separator and
to 4 digits on the right.

8 bytes

AutoNumber

A unique sequential number or a random number
for a new record. Can’t be updated.

4 bytes

Yes/No

Yes and No values (Yes/No, True/False, or On/Off).

1 bit

Table 1: Some Data Types in MS Access

Setting

Description

Decimal precision

Storage size

Byte

Stores numbers from 0

to 255 (no fractions). None

1 byte

Decimal

Stores numbers from
-10”® - 1 through 10%® 28
-1 (.mdb,.accdb)

2 bytes

Integer

Stores numbers from
-32,768t0 32, 767 (no
fractions).

None

2 bytes

(Default) Stores numbers
from -2, 147, 483, 648 to

Long Integer none

2,147, 483, 647 (no
fractions).

4 bytes

Single

Stores numbers from
-3.402823E38 to
-1.401298E -

45 for negative values
and from 1.401298E - 45
to
3.402823E38 for positive
values.

4 bytes

Double

Stores numbers from
-1.79769313486231E308
to -4.94065645841247E
- 324 for negative values

and from 15
4.94065645841247E -
324 to
1.79769313486231E308
for positive values.

8 bytes

Table 2: Number Types in MS Access




